Wyskakujące GIFy/Video w przeglądarce iOS

Szukałem już w Google i nie moge znaleźć rozwiązania. Jak przeglądam memy itd to kiedy trafię na jakiś gif to i Chrome i safari traktują go jak Video i pokazują odtwarzacz (chyba jakiś iphonowski standardowy). Od razu też wrzuca to w full screen co samo w sobie jest irytujące. Co mnie jednak doprowadza do płaczu to to, ze jak już obejrzę i zamknę full screen to kiedy przesunę witrynę w dół to ten gif wyskakuje znowu na pełny ekran. I tak za każdym razem póki kawałek po kawałku, zamykając fullscreen kilka razy nie przesunę tego gifa za górną krawędź.
Już wyłączyłem autoplay w zdjęciach, w dostępności bo tak znalazłem na Google ale to nie to.
Dzieje się identycznie w safari i w Chrome. W Apple reddita zresztą też. To chyba coś z tym odtwarzaczem Video, ale gdzie on ma swoje opcje?

Nie spotkałem się nigdy z tym. Możesz wrzucić przykład? Stronę itd. Może nagrać ekran jak to się dzieje?

Np. tutaj:

1 polubienie

Tak to wyglada. Poza pierwszym otwarciem gifu palec jak przesuwam ekran specjalnie trzymam nie na gifie tylko gdzieś na tekście.
Nie mogłem wrzucić pliku na forum bo wyskakiwał mi jakiś błąd to wrzuciłem na yt.
https://youtube.com/shorts/Edae4UHdBmA?feature=share

Mocno się obawiam, że rozwiązaniem jest omijanie joemonstera i innych.

3 polubienia

Może tak być. Będę z tym żył bo zaakceptowałem te wady iPhonów. Ale chciałem wiedzieć czy gdzieś nie ma jakiegoś ustawienia, o którym nie wiem.

2 polubienia

Normalnie gify się po prostu animują w przeglądarce. Nie trzeba robić play. Mam wrażenie że problemem jest wtyczka użyta na stronie joemonster. Próbowałem znaleźć takie zachowanie na innych stronach z video czy gifami i nie mogę.

Tak patrzę na tą stronę na Joe:
To są mp4 a nie gify. Nawet w edge na windows się odpalają jak scrolluje stronę.

4 polubienia

Potwierdzam. Pierwszy raz coś takiego widze. To jak to jest zrobione na JM to :face_with_peeking_eye:

2 polubienia

JoeMonster to jest koszmarny skansen jeśli chodzi o stronę techniczną, zaglądam tam tylko z sentymentu. Albo te gify, albo niektóre filmy w ogóle nie ładują się w Safari, a od jakiegoś czasu przy filmach z YouTube mam komunikat, że nie mogą być odtworzone w tej domenie.

1 polubienie

o kurde, ale :poop: , jeszcze się z tym nie spotkałem przez dekadę z iphonami

próbowałem to zrekonstruować na swoim iP i jak ściągam film swipem w dół z full screena, a następnie szybko scrolluję stronę, to podczas gdy film znowu wchodzi w full screen, strona wciąż reaguje na przesunięcie palcem i pod filmem przesuwa się na tyle, że teraz po wyjściu z filmu ten już znika z pola widoczności

co nie zmienia faktu, że


oficjalna appka reddita nie miała nigdy takich problemów u mnie, nawet z włączonym autoodtwarzaniem wideo

Ok, czyli to faktycznie problem głównie na joemonster. No to nie ma sprawy. Problem rozwiązany. Dzięki za konsultację.

2 polubienia

Ja wiem, że to nie rozwiązuje problemu ale na Androidzie działa :smiley:

2 polubienia

@Wittosuaff pokaż ikonkę forum YWP z androida :joy:.

5 polubień

Badum-tsss

Zepsułem :cry: odswiezyłem jak przestała maleć… I już nie maleje :confused:

Screenshot_20221004-112424~2

No ale wcześniej:

Screenshot_20220916-180138~3
Screenshot_20220918-224902~3
Screenshot_20220919-165520~3
Screenshot_20220920-214022~4
Screenshot_20220921-060817~3
Screenshot_20220922-144100~3

6 polubień

Joemonster ma wersję tradycyjną strony, która próbuje być responsywna. Może to lepiej Ci zadziała? Znajdziesz przełącznik w stopce strony.

1 polubienie

Gościu! Musiałeś aptować gepty, żeby ta ikona wyglądała po ludzku, z czym do ludzi! :grin:

1 polubienie

Ale naprawić się dało, w sumie zajebiscie prosto, w przeciwieństwie do Joe Monstera gdzie jedyna rada to “pogódź się z tym i tam nie wchodź” :grin: